Compiling Fox on MacOS X

NB: Compiling Fox requires XCode version 2.5 (for MacOS X 10.4) or 3.0 (for MacOS X 10.5)

To compile Fox:

alias wget="curl -O"    # For tcsh, remove the "=" and replace it by a space
wget http://switch.dl.sourceforge.net/sourceforge/objcryst/Fox-1.7.7-R1013.tar.bz2 # This is an example, make sure it is up-to-date
tar -xjf Fox-1.7.7-R1013.tar.bz2
mv Fox-1.7.7-R1013 Fox
cd Fox
svn update    # Optional step: this will update to the latest source, and requires subversion (included on MacOS X 10.5)
cd Fox
make -f macosx.mak dist

None: Compile/MacOSX (last edited 2011-06-18 13:05:25 by VincentFavreNicolin)